Internet Ressourcen


Zusätzliches Material zur Vorlesung

Java-Standards

Freie Java-Übersetzer und Interpretierer

Java Developer Kit 1.1.x

In den Vorlesungen und Übungen wird das JDK 1.1.x von Sun Microsystems benutzt. Bei anderen Implementierungen kann es zu Abweichungen kommen.

Achtung!: Es gibt bereits ein JDK 1.2. Dieses ist aber noch in der Erprobungsphase und enthält einige Änderungen zu der Version 1.1.x. Die Änderungen sind zwar überwiegend für die Vorlesung nicht relevant, aber wir empfehlen trotzdem das JDK 1.1.x zu benutzen.

Für Systeme, die nicht oben genannt worden sind (u.a. AmigaOS, u.v.m.) gibt es eine Alternative.
Achtung!: Die Implementierungen ist fehlerhaft und unvollständig!

Entwicklungsumgebungen

Window95/NT

Die angegebenen Entwicklungsumgebungen benötigen das JDK 1.1.x (s.o.) und sind als Demoversionen erhältlich.

Linux/Unix/Windows mit Emacs/XEmacs

Im Uni-Netz ist aus Kompabilitätsgründen standardmäßig Emacs in der Version 19.x installiert. Diese Version ist für die Java-Entwicklung schlecht geeignet. Wir empfehlen XEmacs oder eine neuere Version von Emacs zu benutzen. Die neuere Emacs Version kann im Uni-Netz mit emacs-20.2 gestartet werden.

Die Java-Entwicklung mit Emacs kann man sich weiter erleichtern:

Bücher und Tutorials

Allgemeine Java Seiten

Anschauen/Drucken von PDF-Dateien

Anschauen/Drucken von Postscript-Dateien

Zur Übersicht